Outbound Call Issue
Incident Report for WigWag
Resolved
This incident has been resolved.
Posted Sep 27, 2021 - 10:45 BST
Investigating
We are aware of an outbound call issue and are currently investigating.
Posted Sep 27, 2021 - 10:34 BST
This incident affected: Business Phone Service (WigWag Cloud) (Phone Calls and Numbering).